Resolvendo dependência libgcrypt11 em instalações do Ubuntu - Linux Centro
Linux Tutoriais

Resolvendo dependência libgcrypt11 em instalações do Ubuntu

Você tentou instalar o Spotify ou a IDE de desenvolvimento Brackets em seu Ubuntu, Linux Mint, Xubuntu e qualquer outra variante do sistema operacional da Canonical e recebeu um erro? Calma! Vamos explicar o que houve e lhe auxiliar na correção.

Desde a versão 15.04 do Ubuntu, a biblioteca libgcrypt fora atualizada para a libgcrypt20, como a versão libgcrypt11 tornou-se obsoleta, fora removida dos repositórios oficiais. O problema é que softwares como o Spotify e Brackets ainda usam o anterior, dessa forma, ao tentar instalar, se for pelo pacote deb, o GDebi informará que uma dependência não é contestável e não permitirá a instalação.

Se a tentativa de instalação for pelo terminal, o usuário receberá o seguinte erro:

error while loading shared libraries: libgcrypt.so.11: cannot open shared object file: No such file or directory

A dúvida e a raiva podem surgir nesse momento, mas saiba que a solução é bem simples, enquanto os softwares desejados não atualizam sua dependência, tudo que você precisa fazer é clicar aqui e baixar o libgcrypt11. É um pacote deb, portanto basta dar dois cliques para que ele seja aberto em sua central de programas, depois clicar em “instalar” e digitar sua senha, aguarde a instalação.

Pronto! Agora você pode voltar e instalar o software desejado, que não receberá mais a crítica anterior.

Gostou da nossa dica? Fique por dentro de outras matérias como essa, além de notícias, tutoriais, análises, colunas e muito mais, curta nossa página no facebook para não perder nossas postagens e participe de nossa comunidade no Google Plus para tirar dúvidas, compartilhar conteúdo e interagir com outros leitores. Não esqueça que nosso espaço de comentário é todo seu, sempre que podemos paramos para responder todos.

Please follow and like us:
RSS
Follow by Email
Facebook
Facebook
Twitter
YouTube
YouTube